Conversion DAE file


Hello roboticeyes team and community,
I hope you can help me: I have a problem with conversion a DAE file.
I have exported the DAE file from Nemetschek Allplan. Now I have a DAE file and many texture files.
If I just upload the DAE file directly to the 3D model and watch it on the REX go app, it looks like this:

It should be a wall with a window. (see below)
But it only shows me some individual surfaces; not the whole wall.

If I upload it on the REX lizard, it stops at 3% and tells me “error”.

This is how it looks like in Nemetschek Allplan:

Now I do not know what I’m doing wrong.
Please give me advice on how to convert the file.
kind regards&many thanks


Hello schulte_mhafner,

thanks for reaching out to us.

There are a few things to keep in mind when importing DAE files into REX.

  • All shapes have to be exported as triangles when saving the DAE from 3D tools (most of the tools have an option like ‘triangulate faces’ upon DAE export)
  • If the DAE has additional texture files (JPG or PNG), one can pack the DAE plus the texture files into a ZIP file and upload that onto REX

You can see any problems with your file in the ‘Ingest Jobs’ page.

Click on the user-icon on the top right of the page and select ‘Ingest Jobs’.
On this page there is a statistics symbol next to the status if you hover over it:

Any errors during conversion are listed here (see example below):


okay, thank you.

I dont have any option like “triangulation” in the program Allplan.
But tomorrow I call the Allplan hotline; maybe they have an idea to export the file.

btw: this ist my statistics, no “error” nevertheless only a few faces in REX…


Did you submit a ZIP file with the contained texutre files?

It may happen that your exported .dae file contains absolute URLs pointing to the texture files. Since the triangle count is 118, the geometry seems to be fine already. For further analysis you can send your ZIP file with the .dae and all texture files to Also Umlauts in the texture files may lead to troubles.


Thank you very much for your advice.
I have no idea yet. Even when I upload the zip file with the textures (without Umlauts) it works in here. But in the REXgo app it’s always the same like I describe above.
Now I have sent my zip file to the support. Maybe we will find the mistake together. :slight_smile:


We just analysed your files. The textures should be fine, but the main problem is that your model has faces which are not fully triangulated.

If your CAD application does not support triangulated output out of the box, you can use SketchUp to import and export (triangulated) COLLADA files. We forwarded your problem to our development team for future improvements.

Here the option dialog for SketchUp: